Skip to content
Public Ticket #17229

Error 503 when enabling penci pagespeed optimizer

Conversation thread

Warren Lee replied

Customer Reply

Hello, this has been resolved. Disabled by typing phpdismod opcache into Ubuntu terminal line. Thanks!

PenciDesign Supporter replied

Staff Reply

Hi,

I've checked and the OP Cache still enable on your site.

In this case, please contact DigitalOcean support to help you disable this feature.

Regards,
PenciDesign.


Warren Lee replied

Customer Reply

Hi, I have added a opcache.ini file to the directory you mentioned, even edited the php.ini in the /etc/php/8.0/apache2 folder with opache.enabled=0 command.Still doesn't work.

PenciDesign Supporter replied

Staff Reply

Hi,

Your site currently enables Zend OPcache, please SSH in as root and edit the following files:

/etc/php8.0.7-sp/conf.d/opcache.ini

Add the following line to the end of each of these files:

opcache.enable=0

Finally, restart the PHP version by running the following command as root:

sudo service php8.0.7-fpm-sp restart

Regards,
PenciDesign.

Warren Lee replied

Customer Reply

Hello, as I'm using Ubuntu Server on DigitalOcean, how do i get about on this as I don't have cpanel? Thanks!

PenciDesign Supporter replied

Staff Reply

Hi,

In some case, if you using PHP 8, you can get an error 503 issue after activating the plugin Penci PageSpeed Optimizer - you just need to go to your hosting > Cpanel > Select PHP Version > click on the "Extensions" tab and disable the opcache extension - check the image below:

assets%2F-MYNqsVWdjtnuDIOHong%2F-M_8uaY3r-pqj7YKwDFY%2F-M_8vlfVk5xaxOCjotWr%2Fopcache.png?alt=media&token=686446fd-77e3-417a-adb3-b5de9387ebbd

For more information, please read the document here: https://optimize.pencidesign.net/

Regards,
PenciDesign.

Warren Lee started the conversation

Conversation Start

Hi Support, I encountered the attached error when activating the penci pagespeed plugin, can you help to see what is the problem?

Want to join this conversation or access attachments? Sign in first.